re = /((CREATE.*my_table.*\n)|(\s+.*tinyint.*\n)|(\s+.*(?!tinyint)\n))/
str = 'CREATE TABLE `my_table` (
`id` bigint(20) NOT NULL,
`id2` bigint(27) NULL,
`REVTYPE` tinyint(4) DEFAULT NULL,
`REVTYPE2` bigint(52) blahblah,
`REVTYPE` tinyint(7) stuff
`some_other_column` varchar(255)
);'
subst = '$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result