const regex = /((CREATE.*my_table.*\n)|(\s+.*tinyint.*\n)|(\s+.*(?!tinyint)\n))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((CREATE.*my_table.*\\n)|(\\s+.*tinyint.*\\n)|(\\s+.*(?!tinyint)\\n))', 'g')
const str = `CREATE TABLE \`my_table\` (
\`id\` bigint(20) NOT NULL,
\`id2\` bigint(27) NULL,
\`REVTYPE\` tinyint(4) DEFAULT NULL,
\`REVTYPE2\` bigint(52) blahblah,
\`REVTYPE\` tinyint(7) stuff
\`some_other_column\` varchar(255)
);`;
const subst = `$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);