package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|/)[[:alpha:]]*[[:digit:]][[:alnum:]]*($|/)`)
var str = `/example/endpoint/here/34456dwf45
/endpoint/fddk449372
/434236/example/endpoint`
var substitution = "\1my_var\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}