re = /(^|\/)[[:alpha:]]*[[:digit:]][[:alnum:]]*($|\/)/m
str = '/example/endpoint/here/34456dwf45
/endpoint/fddk449372
/434236/example/endpoint'
subst = '\\1my_var\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result