import re
regex = re.compile(r"(^|/)[[:alpha:]]*[[:digit:]][[:alnum:]]*($|/)", flags=re.MULTILINE)
test_str = ("/example/endpoint/here/34456dwf45\n"
"/endpoint/fddk449372\n"
"/434236/example/endpoint")
subst = "\\1my_var\\2"
result = regex.sub(subst, test_str)
if result:
print(result)