import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|/)[[:alpha:]]*[[:digit:]][[:alnum:]]*($|/)";
final String string = "/example/endpoint/here/34456dwf45\n"
+ "/endpoint/fddk449372\n"
+ "/434236/example/endpoint";
final String subst = "\\1my_var\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}