const regex = new RegExp('(^|/)[[:alpha:]]*[[:digit:]][[:alnum:]]*($|/)', 'gm')
const str = `/example/endpoint/here/34456dwf45
/endpoint/fddk449372
/434236/example/endpoint`;
const subst = `\1my_var\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);