# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+),([^,]+),(\d+),([0-9\.]+)$/UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2");/gm;t' <<< "24,ELA.4,12,9.09
"