package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+),([^,]+),(\d+),([0-9\.]+)$`)
var str = `24,ELA.4,12,9.09
`
var substitution = "UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2");"
fmt.Println(re.ReplaceAllString(str, substitution))
}