// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+),([^,]+),(\d+),([0-9\.]+)$").unwrap();
let string = "24,ELA.4,12,9.09
";
let substitution = "UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = \"$2\");";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}