import re
regex = re.compile(r"^(\d+),([^,]+),(\d+),([0-9\.]+)$", flags=re.MULTILINE)
test_str = ("24,ELA.4,12,9.09\n")
subst = "UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = \"$2\");"
result = regex.sub(subst, test_str)
if result:
print(result)