re = /^(\d+),([^,]+),(\d+),([0-9\.]+)$/m
str = '24,ELA.4,12,9.09
'
subst = 'UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2");'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result