import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+),([^,]+),(\\d+),([0-9\\.]+)$";
final String string = "24,ELA.4,12,9.09\n";
final String subst = "UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = \"$2\");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}