const regex = /^(\d+),([^,]+),(\d+),([0-9\.]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+),([^,]+),(\\d+),([0-9\\.]+)$', 'gm')
const str = `24,ELA.4,12,9.09
`;
const subst = `UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2");`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);