import Foundation
let pattern = #"^(\d+),([^,]+),(\d+),([0-9\.]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
24,ELA.4,12,9.09
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"UPDATE cbl_student_competencies SET BaselineRating = $4 WHERE StudentID = $1 AND Level = $3 AND CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = "$2");"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)