using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\t*)(\/\*\*\n(\t* \*.*\n)\t* \*\/\n)";
string substitution = @"$1/\*\*\n$1 \* @package Polylang-Pro\n$3$1 \*/\n";
string input = @" /**
* @param WP_Post $post
*/
public function get_translations( $post ) {
// My code
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}