import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\t*)(\\/\\*\\*\\n(\\t* \\*.*\\n)\\t* \\*\\/\\n)";
final String string = " /**\n"
+ " * @param WP_Post $post\n"
+ " */\n"
+ " public function get_translations( $post ) {\n"
+ " // My code\n"
+ " }";
final String subst = "$1/\\*\\*\\n$1 \\* @package Polylang-Pro\\n$3$1 \\*/\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}