import Foundation
let pattern = #"(\t*)(\/\*\*\n(\t* \*.*\n)\t* \*\/\n)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/**
* @param WP_Post $post
*/
public function get_translations( $post ) {
// My code
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/\*\*\n$1 \* @package Polylang-Pro\n$3$1 \*/\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)