re = /(\t*)(\/\*\*\n(\t* \*.*\n)\t* \*\/\n)/m
str = ' /**
* @param WP_Post $post
*/
public function get_translations( $post ) {
// My code
}'
subst = '$1/\\*\\*\\n$1 \\* @package Polylang-Pro\\n$3$1 \\*/\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result