import re
regex = re.compile(r"(\t*)(\/\*\*\n(\t* \*.*\n)\t* \*\/\n)", flags=re.MULTILINE)
test_str = (" /**\n"
" * @param WP_Post $post\n"
" */\n"
" public function get_translations( $post ) {\n"
" // My code\n"
" }")
subst = "$1/\\*\\*\\n$1 \\* @package Polylang-Pro\\n$3$1 \\*/\\n"
result = regex.sub(subst, test_str)
if result:
print(result)