// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\t*)(\/\*\*\n(\t* \*.*\n)\t* \*\/\n)").unwrap();
let string = " /**
* @param WP_Post $post
*/
public function get_translations( $post ) {
// My code
}";
let substitution = "$1/\\*\\*\\n$1 \\* @package Polylang-Pro\\n$3$1 \\*/\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}