const regex = new RegExp('(\\t*)(\\/\\*\\*\\n(\\t* \\*.*\\n)\\t* \\*\\/\\n)', 'gm')
const str = ` /**
* @param WP_Post \$post
*/
public function get_translations( \$post ) {
// My code
}`;
const subst = `$1/\*\*\n$1 \* @package Polylang-Pro\n$3$1 \*/\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);