#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[[:alnum:]]+/[[:alnum:]]+\)(?:-[[:alnum:]]+){3}"
Local $sString = "[[1]]" & @CRLF & _
"abc/a3d)-1-B-3-B" & @CRLF & _
"" & @CRLF & _
"[[2]]" & @CRLF & _
"dec/d93)-B-1-3" & @CRLF & _
"" & @CRLF & _
"[[3]]" & @CRLF & _
"vdiek/asdf899)-1-B-B-B-1-3-4" & @CRLF & _
"" & @CRLF & _
"[[4]]" & @CRLF & _
"avd/asd/vde)-1-B-3-4" & @CRLF & _
"" & @CRLF & _
"[[5]]" & @CRLF & _
"ab33/dfv)-B-12-B" & @CRLF & _
"" & @CRLF & _
"[[6]]" & @CRLF & _
"abc/ade)-1" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")