const regex = new RegExp('^[[:alnum:]]+/[[:alnum:]]+\\)(?:-[[:alnum:]]+){3}', 'mg')
const str = `[[1]]
abc/a3d)-1-B-3-B
[[2]]
dec/d93)-B-1-3
[[3]]
vdiek/asdf899)-1-B-B-B-1-3-4
[[4]]
avd/asd/vde)-1-B-3-4
[[5]]
ab33/dfv)-B-12-B
[[6]]
abc/ade)-1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}