re = /^[[:alnum:]]+\/[[:alnum:]]+\)(?:-[[:alnum:]]+){3}/m
str = '[[1]]
abc/a3d)-1-B-3-B
[[2]]
dec/d93)-B-1-3
[[3]]
vdiek/asdf899)-1-B-B-B-1-3-4
[[4]]
avd/asd/vde)-1-B-3-4
[[5]]
ab33/dfv)-B-12-B
[[6]]
abc/ade)-1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end