// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[[:alnum:]]+/[[:alnum:]]+\)(?:-[[:alnum:]]+){3}").unwrap();
let string = "[[1]]
abc/a3d)-1-B-3-B
[[2]]
dec/d93)-B-1-3
[[3]]
vdiek/asdf899)-1-B-B-B-1-3-4
[[4]]
avd/asd/vde)-1-B-3-4
[[5]]
ab33/dfv)-B-12-B
[[6]]
abc/ade)-1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}