import re
regex = re.compile(r"^[[:alnum:]]+/[[:alnum:]]+\)(?:-[[:alnum:]]+){3}", flags=re.MULTILINE)
test_str = ("[[1]]\n"
"abc/a3d)-1-B-3-B\n\n"
"[[2]]\n"
"dec/d93)-B-1-3\n\n"
"[[3]]\n"
"vdiek/asdf899)-1-B-B-B-1-3-4\n\n"
"[[4]]\n"
"avd/asd/vde)-1-B-3-4\n\n"
"[[5]]\n"
"ab33/dfv)-B-12-B\n\n"
"[[6]]\n"
"abc/ade)-1\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")