#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)goDetail\(\'(\w+).*\'([\d-]+\(\d+\))"
Local $sString = "<tbody>" & @CRLF & _
"<tr class="td_odd" onclick="goDetail('101','70-1-44-1(035)')"" & @CRLF & _
"style="cursor:pointer;">" & @CRLF & _
"<td align="center" valign="middle">1</td>" & @CRLF & _
"<td align="center" class="td-line" valign="middle">效期內</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr class="td_event" onclick="goDetail('301','40-107-4-1(9918)')"" & @CRLF & _
"style="cursor:pointer;">" & @CRLF & _
"<td align="center" valign="middle">2</td>" & @CRLF & _
"<td align="center" class="td-line" valign="middle">效期內</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr class="td_odd" onclick="goDetail('502','53-1-42-1(531)')"" & @CRLF & _
"style="cursor:pointer;">" & @CRLF & _
"<td align="center" valign="middle">1</td>" & @CRLF & _
"<td align="center" class="td-line" valign="middle">效期內</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")