import re
regex = re.compile(r"goDetail\(\'(\w+).*\'([\d-]+\(\d+\))", flags=re.MULTILINE)
test_str = ("<tbody>\n"
"<tr class=\"td_odd\" onclick=\"goDetail('101','70-1-44-1(035)')\"\n"
"style=\"cursor:pointer;\">\n"
"<td align=\"center\" valign=\"middle\">1</td>\n"
"<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>\n"
"</tr>\n"
"<tr class=\"td_event\" onclick=\"goDetail('301','40-107-4-1(9918)')\"\n"
"style=\"cursor:pointer;\">\n"
"<td align=\"center\" valign=\"middle\">2</td>\n"
"<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>\n"
"</tr>\n"
"<tr class=\"td_odd\" onclick=\"goDetail('502','53-1-42-1(531)')\"\n"
"style=\"cursor:pointer;\">\n"
"<td align=\"center\" valign=\"middle\">1</td>\n"
"<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>\n"
"</tr>\n"
"</tbody>\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")