$re = '/goDetail\(\'(\w+).*\'([\d-]+\(\d+\))/m';
$str = '<tbody>
<tr class="td_odd" onclick="goDetail(\'101\',\'70-1-44-1(035)\')"
style="cursor:pointer;">
<td align="center" valign="middle">1</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
<tr class="td_event" onclick="goDetail(\'301\',\'40-107-4-1(9918)\')"
style="cursor:pointer;">
<td align="center" valign="middle">2</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
<tr class="td_odd" onclick="goDetail(\'502\',\'53-1-42-1(531)\')"
style="cursor:pointer;">
<td align="center" valign="middle">1</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
</tbody>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);