use strict;
my $str = '<tbody>
<tr class="td_odd" onclick="goDetail(\'101\',\'70-1-44-1(035)\')"
style="cursor:pointer;">
<td align="center" valign="middle">1</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
<tr class="td_event" onclick="goDetail(\'301\',\'40-107-4-1(9918)\')"
style="cursor:pointer;">
<td align="center" valign="middle">2</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
<tr class="td_odd" onclick="goDetail(\'502\',\'53-1-42-1(531)\')"
style="cursor:pointer;">
<td align="center" valign="middle">1</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
</tbody>
';
my $regex = qr/goDetail\(\'(\w+).*\'([\d-]+\(\d+\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}