const regex = new RegExp('goDetail\\(\\\\'(\\w+).*\\\\'([\\d-]+\\(\\d+\\))', 'gm')
const str = `<tbody>
<tr class="td_odd" onclick="goDetail('101','70-1-44-1(035)')"
style="cursor:pointer;">
<td align="center" valign="middle">1</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
<tr class="td_event" onclick="goDetail('301','40-107-4-1(9918)')"
style="cursor:pointer;">
<td align="center" valign="middle">2</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
<tr class="td_odd" onclick="goDetail('502','53-1-42-1(531)')"
style="cursor:pointer;">
<td align="center" valign="middle">1</td>
<td align="center" class="td-line" valign="middle">效期內</td>
</tr>
</tbody>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}