import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "goDetail\\(\\'(\\w+).*\\'([\\d-]+\\(\\d+\\))";
final String string = "<tbody>\n"
+ "<tr class=\"td_odd\" onclick=\"goDetail('101','70-1-44-1(035)')\"\n"
+ "style=\"cursor:pointer;\">\n"
+ "<td align=\"center\" valign=\"middle\">1</td>\n"
+ "<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>\n"
+ "</tr>\n"
+ "<tr class=\"td_event\" onclick=\"goDetail('301','40-107-4-1(9918)')\"\n"
+ "style=\"cursor:pointer;\">\n"
+ "<td align=\"center\" valign=\"middle\">2</td>\n"
+ "<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>\n"
+ "</tr>\n"
+ "<tr class=\"td_odd\" onclick=\"goDetail('502','53-1-42-1(531)')\"\n"
+ "style=\"cursor:pointer;\">\n"
+ "<td align=\"center\" valign=\"middle\">1</td>\n"
+ "<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>\n"
+ "</tr>\n"
+ "</tbody>\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}