using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"goDetail\(\'(\w+).*\'([\d-]+\(\d+\))";
string input = @"<tbody>
<tr class=""td_odd"" onclick=""goDetail('101','70-1-44-1(035)')""
style=""cursor:pointer;"">
<td align=""center"" valign=""middle"">1</td>
<td align=""center"" class=""td-line"" valign=""middle"">效期內</td>
</tr>
<tr class=""td_event"" onclick=""goDetail('301','40-107-4-1(9918)')""
style=""cursor:pointer;"">
<td align=""center"" valign=""middle"">2</td>
<td align=""center"" class=""td-line"" valign=""middle"">效期內</td>
</tr>
<tr class=""td_odd"" onclick=""goDetail('502','53-1-42-1(531)')""
style=""cursor:pointer;"">
<td align=""center"" valign=""middle"">1</td>
<td align=""center"" class=""td-line"" valign=""middle"">效期內</td>
</tr>
</tbody>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}