#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\\)![^!\\.]*(?:(?:\.(?!\.\.)|(?=(\.{3}.*?\.{3}))\1|\\.)[^!\\.]*)*!"
Local $sString = "!Normal string!" & @CRLF & _
"!String with escaped \! exclamation mark!" & @CRLF & _
"!String with a comment ... comment ...!" & @CRLF & _
"!String \! with both ... comments can have unescaped exclamation marks!!!... !" & @CRLF & _
"" & @CRLF & _
"test ...this is a comment... test" & @CRLF & _
"" & @CRLF & _
"\!String \! with both ... comments can have unescaped exclamation marks!!!...... !" & @CRLF & _
"" & @CRLF & _
"!S...test...\!tring \! with both ... comments can have unescaped exclamation marks ...test...\!tring \! with both ... comments can have unescaped exclamation marks ...test...\!tring \! with both ... comments can have unescaped exclamation marks ...test...\!tring \! with both ... comments can have unescaped exclamation marks ...test...\!tring \! with both ... comments can have unescaped exclamation marks " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")