use strict;
my $str = '!Normal string!
!String with escaped \\! exclamation mark!
!String with a comment ... comment ...!
!String \\! with both ... comments can have unescaped exclamation marks!!!... !
test ...this is a comment... test
\\!String \\! with both ... comments can have unescaped exclamation marks!!!...... !
!S...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks
';
my $regex = qr/(?<!\\)![^!\\.]*(?:(?:\.(?!\.\.)|(?=(\.{3}.*?\.{3}))\1|\\.)[^!\\.]*)*!/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}