$re = '/(?<!\\\\)![^!\\\\.]*(?:(?:\.(?!\.\.)|(?=(\.{3}.*?\.{3}))\1|\\\\.)[^!\\\\.]*)*!/m';
$str = '!Normal string!
!String with escaped \\! exclamation mark!
!String with a comment ... comment ...!
!String \\! with both ... comments can have unescaped exclamation marks!!!... !
test ...this is a comment... test
\\!String \\! with both ... comments can have unescaped exclamation marks!!!...... !
!S...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);