using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)![^!\\.]*(?:(?:\.(?!\.\.)|(?=(\.{3}.*?\.{3}))\1|\\.)[^!\\.]*)*!";
string input = @"!Normal string!
!String with escaped \! exclamation mark!
!String with a comment ... comment ...!
!String \! with both ... comments can have unescaped exclamation marks!!!... !
test ...this is a comment... test
\!String \! with both ... comments can have unescaped exclamation marks!!!...... !
!S...test...\!tring \! with both ... comments can have unescaped exclamation marks ...test...\!tring \! with both ... comments can have unescaped exclamation marks ...test...\!tring \! with both ... comments can have unescaped exclamation marks ...test...\!tring \! with both ... comments can have unescaped exclamation marks ...test...\!tring \! with both ... comments can have unescaped exclamation marks
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}