const regex = new RegExp('(?<!\\\\)![^!\\\\.]*(?:(?:\\.(?!\\.\\.)|(?=(\\.{3}.*?\\.{3}))\\1|\\\\.)[^!\\\\.]*)*!', 'gm')
const str = `!Normal string!
!String with escaped \\! exclamation mark!
!String with a comment ... comment ...!
!String \\! with both ... comments can have unescaped exclamation marks!!!... !
test ...this is a comment... test
\\!String \\! with both ... comments can have unescaped exclamation marks!!!...... !
!S...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}