import re
regex = re.compile(r"(?<!\\)![^!\\.]*(?:(?:\.(?!\.\.)|(?=(\.{3}.*?\.{3}))\1|\\.)[^!\\.]*)*!", flags=re.MULTILINE)
test_str = ("!Normal string!\n"
"!String with escaped \\! exclamation mark!\n"
"!String with a comment ... comment ...!\n"
"!String \\! with both ... comments can have unescaped exclamation marks!!!... !\n\n"
"test ...this is a comment... test\n\n"
"\\!String \\! with both ... comments can have unescaped exclamation marks!!!...... !\n\n"
"!S...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks \n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")