import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<tgl>\\d{2})\\/(?<bln>[0-1][0-9]{1,2})\\/(?<thn>\\d{4})$";
final String string = "90/09/2018";
final String subst = "Gafur";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}