const regex = /^(?<tgl>\d{2})\/(?<bln>[0-1][0-9]{1,2})\/(?<thn>\d{4})$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<tgl>\\d{2})\\\/(?<bln>[0-1][0-9]{1,2})\\\/(?<thn>\\d{4})$', 's')
const str = `90/09/2018`;
const subst = `Gafur`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);