re = /^(?<tgl>\d{2})\/(?<bln>[0-1][0-9]{1,2})\/(?<thn>\d{4})$/
str = '90/09/2018'
subst = 'Gafur'
result = str.sub(re, subst)
# Print the result of the substitution
puts result