# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(("|]|}|\.|(\d|\.|-|:)\s*\d)\s*,|{)\s*(")?([^":\n]+?)(")?\s*:/$1"$5":/g;t' <<< "{
type:\"book\",
author:[\"Willighagen, LG\"],
editor:[\"Toos van Hoof\",\"Karin Antoinette Henriette Majoor\"],
date:
{
from:{
from:[1,2,2003],
}
}
,
print:3,
}"