using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((""|]|}|\.|(\d|\.|-|:)\s*\d)\s*,|{)\s*("")?([^"":\n]+?)("")?\s*:";
string substitution = @"$1""$5"":";
string input = @"{
type:""book"",
author:[""Willighagen, LG""],
editor:[""Toos van Hoof"",""Karin Antoinette Henriette Majoor""],
date:
{
from:{
from:[1,2,2003],
}
}
,
print:3,
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}