package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(("|]|}|\.|(\d|\.|-|:)\s*\d)\s*,|{)\s*(")?([^":\n]+?)(")?\s*:`)
var str = `{
type:"book",
author:["Willighagen, LG"],
editor:["Toos van Hoof","Karin Antoinette Henriette Majoor"],
date:
{
from:{
from:[1,2,2003],
}
}
,
print:3,
}`
var substitution = "$1"$5":"
fmt.Println(re.ReplaceAllString(str, substitution))
}