import re
regex = re.compile(r"((\"|]|}|\.|(\d|\.|-|:)\s*\d)\s*,|{)\s*(\")?([^\":\n]+?)(\")?\s*:")
test_str = ("{\n"
"type:\"book\",\n"
"author:[\"Willighagen, LG\"],\n"
"editor:[\"Toos van Hoof\",\"Karin Antoinette Henriette Majoor\"],\n"
"date:\n"
"{\n"
"from:{\n"
"from:[1,2,2003],\n"
"}\n"
"}\n"
",\n"
"print:3,\n"
"}")
subst = "$1\"$5\":"
result = regex.sub(subst, test_str)
if result:
print(result)