$re = '/(("|]|}|\.|(\d|\.|-|:)\s*\d)\s*,|{)\s*(")?([^":\n]+?)(")?\s*:/';
$str = '{
type:"book",
author:["Willighagen, LG"],
editor:["Toos van Hoof","Karin Antoinette Henriette Majoor"],
date:
{
from:{
from:[1,2,2003],
}
}
,
print:3,
}';
$subst = "$1\"$5\":";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;