import Foundation
let pattern = #"(("|]|}|\.|(\d|\.|-|:)\s*\d)\s*,|{)\s*(")?([^":\n]+?)(")?\s*:"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
type:"book",
author:["Willighagen, LG"],
editor:["Toos van Hoof","Karin Antoinette Henriette Majoor"],
date:
{
from:{
from:[1,2,2003],
}
}
,
print:3,
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"$5":"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)