// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(("|]|}|\.|(\d|\.|-|:)\s*\d)\s*,|{)\s*(")?([^":\n]+?)(")?\s*:"#).unwrap();
let string = "{
type:\"book\",
author:[\"Willighagen, LG\"],
editor:[\"Toos van Hoof\",\"Karin Antoinette Henriette Majoor\"],
date:
{
from:{
from:[1,2,2003],
}
}
,
print:3,
}";
let substitution = "$1\"$5\":";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}